References to this incident have disappeared from Microsoft's status pages, there has been no 'issue resolved' status update, it has just been removed. We can only assume they have resolved the issue although we believe there are ongoing issues affecting M365.
Posted Oct 30, 2025 - 13:52 NZDT
Update
Microsoft have deployed 'last known good' configuration and further recovery work is ongoing. ETA for full mitigation is within 4 hours.
Posted Oct 30, 2025 - 08:47 NZDT
Identified
Microsoft progress is ongoing. Some services may show signs of initial recovery. No confirmed ETA for full restoration of services.
Posted Oct 30, 2025 - 08:07 NZDT
Investigating
All Microsoft services worldwide appear to be affected by a widespread major outage. We have no information about the incident and no ETA for restoration of Microsoft's services.
Posted Oct 30, 2025 - 07:37 NZDT
This incident affected: 3rd Party Systems (Azure, Office 365).